How can I update the Firmware on my Triggertrap v1?

To update the firmware on your Triggertrap v1, please follow these instructions carefully.

If you can't get the update to work, things to look out for are:

  1. Did you download all the files? If you don't know how to use Git, either learn :-) or look at the right-hand side of the Github page, there's a link to a Zip file. If you download that one, you get all the files you ned.
  2. Did you definitely follow step 7? If you didn't, you've just uploaded the Triggertrap Shield for Arduino code onto your v1, which won't work.
  3. Do you get a 'cannot compile' error? Check that your libraries are in the right place.
  4. Still stuck? Ask for help in the forums!